home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / dev-perl / gtk-perl-0.7009-r2 / gtk-perl-0.7009-r2.ebuild < prev    next >
Text File  |  2006-05-02  |  2KB  |  55 lines

  1. # Copyright 1999-2006 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/dev-perl/gtk-perl/gtk-perl-0.7009-r2.ebuild,v 1.8 2006/03/24 19:10:32 agriffis Exp $
  4.  
  5. inherit perl-module eutils
  6.  
  7. MY_P=Gtk-Perl-${PV}
  8. S=${WORKDIR}/${MY_P}
  9. DESCRIPTION="Perl bindings for GTK"
  10. SRC_URI="mirror://cpan/authors/id/M/ML/MLEHMANN/${MY_P}.tar.gz"
  11. HOMEPAGE="http://search.cpan.org/~mlehmann/${MY_P}/"
  12. IUSE="gtkhtml gnome-print applet gnome opengl"
  13. SLOT="0"
  14. LICENSE="GPL-2"
  15. KEYWORDS="~amd64 hppa ppc sparc x86"
  16.  
  17. DEPEND="${DEPEND}
  18.     media-libs/gdk-pixbuf
  19.     =x11-libs/gtk+-1.2*
  20.     dev-perl/XML-Writer
  21.     dev-perl/XML-Parser
  22.     opengl? ( =x11-libs/gtkglarea-1.2* )
  23.     gnome? ( gnome-base/gnome-libs
  24.             gnome-print? ( gnome-base/gnome-print )
  25.             applet? ( =gnome-base/gnome-applets-1.4.0.5 ) )
  26.     gtkhtml? ( =gnome-extra/gtkhtml-1* )"
  27.  
  28. mydoc="VERSIONS WARNING NOTES"
  29.  
  30. use gnome || myconf="${myconf} --without-gnome"
  31. use gnome-print || myconf="${myconf} --without-gnomeprint"
  32. use applet || myconf="${myconf} --without-applets"
  33. use opengl || myconf="${myconf} --without-gtkglarea"
  34.  
  35. src_unpack() {
  36.  
  37.     unpack ${A}
  38.     cd ${S}
  39.     use gnome || einfo "${PN} being built without gnome support"
  40.     use gnome-print || einfo "${PN} being built without gnome-print support"
  41.     use applet || einfo "${PN} being built without gnome-applets-1.4 support"
  42.  
  43.     epatch ${FILESDIR}/gendef.patch
  44.     perl -pi -e '/CCMD/ && s|/m;|/mg;|' */Makefile.PL
  45.     sed -i 's/MesaGL/GL/g' GtkGLArea/Makefile.PL
  46.     sed -i 's/MesaGL/GL/g' GtkGLArea/pkg.pl
  47. }
  48.  
  49. src_compile() {
  50.  
  51.     # the makemakersixeleven syntax doesn't seem to work
  52.     perl Makefile.PL ${myconf} \
  53.     PREFIX=${D}/usr INSTALLDIRS=vendor
  54. }
  55.